Two Pilots™    Home  |  Navigation  |  Site Map  |  Products  |  Download  |  Prices  |  For Partners  |  Support


All forums · Statistics · Search ·

Two Pilots forum / For software developers / HTML2PDF Crash
Author Message
ThomasP
# Posted: 28 Feb 2007 02:17


I am using HTML2PDF 3.4.6 + PDFCreatorPilot 3.2 (last version recieved by mail)

There is a crash when I try to convert a simple page : Here is the log page :

02/28/07 09:12:47 HTML2PDFImpl - Running version 3.4.6.0.
02/28/07 09:12:47 HTML2PDFImpl - Provided regname XXXXXX
02/28/07 09:12:47 HTML2PDFImpl - Provided registration data is valid.
02/28/07 09:12:49 HTML2PDFImpl - Adjust Content set to 1
02/28/07 09:12:50 HTML2PDFImpl - Use Links set to 0
02/28/07 09:12:51 HTML2PDFImpl - PDFInterface released
02/28/07 09:12:51 HTML2PDFImpl - PDFInterface released
02/28/07 09:12:51 HTML2PDFImpl - ImageCreator created
02/28/07 09:12:51 CBrowserWindow - Created
02/28/07 09:12:51 CBrowserWindow - Arrived OnDocumentComplete for about:blank (0x7C74160)
02/28/07 09:12:51 CBrowserWindow - Arrived OnDocumentComplete for about:blank (0x7C74160)
02/28/07 09:12:51 CBrowserWindow - Loaded. Ready to convert
02/28/07 09:12:51 CBrowserWindow - Conversion routine called for (0x7C92140)
02/28/07 09:12:51 ImageCreator - Conversion routine called for (0x7C92140)
02/28/07 09:12:51 ImageCreator - Save image called for (0x7C92140)
02/28/07 09:12:51 ImageCreator - Metafile 800 x 546 created
02/28/07 09:12:51 ImageCreator - Trying to draw (0x7C92410)
02/28/07 09:12:51 ImageCreator - Compatibility string is 'BackCompat'
02/28/07 09:12:51 ImageCreator - Standards-compliant mode is NOT switched on.
02/28/07 09:12:51 ImageCreator - Trying conservative way to draw
02/28/07 09:12:51 ImageCreator - Conservative way to draw succeeded
02/28/07 09:12:51 CBrowserWindow - Destroyed
02/28/07 09:12:51 CBrowserWindow - Destroyed
02/28/07 09:12:51 HTML2PDFImpl - Download complete
02/28/07 09:12:51 HTML2PDFImpl - Metafile created

the crash occurs when using LoadHTMLString

Could you solve tis problem

Thanks.

mvf
Member
# Posted: 28 Feb 2007 23:13


Thank you. Our developers will be informed about this problem.

mvf
Member
# Posted: 1 Mar 2007 04:01


Can we see the string you tried to convert by LoadHTMLString ?

ThomasP
# Posted: 2 Mar 2007 04:53


the htmlcode :

<style type="text/css">

</style><TABLE WIDTH='100%' CELLPADDING=5><TR><TD><style type="text/css">
.MSI {FONT-FAMILY:Verdana;FONT-SIZE:9pt;FONT-WEIGHT:bol d;PADDING:4px;}.MS {FONT-FAMILY:Verdana;FONT-SIZE:9pt;}.MN {FONT-FAMILY:Verdana;FONT-SIZE:8pt;}.TT {FONT-SIZE:9pt;FONT-FAMILY:Verdana}.BD {FONT-SIZE:9pt;FONT-FAMILY:Verdana}.RST {text-transform:uppercase;FONT-FAMILY:Verdana;back ground-color:#d8e7f1;FONT-SIZE:10pt;text-align:cen ter;font-weight:bold;padding:3px;}.RSST {FONT-FAMILY:Verdana;FONT-SIZE:8pt;text-align:cent er;}.RSST IMG{vertical-align:middle;}.RST IMG{vertical-align:middle;}
</style></HEAD><BODY><DIV CLASS=RST><SPAN ID='RPL_name'>test (1)</SPAN> </DIV><BR><table><tr><td><table border=0 CELLSPACING=0 CELLPADDING=0 bgcolor=white><tr><td height=9px width=1px rowspan=9 bgcolor=blue></td><td colspan=4 width=4px></td></tr><tr><td height=7px width=1px rowspan=7 bgcolor=blue></td><td colspan=3 width=3px></td></tr><tr><td height=5px width=1px rowspan=5 bgcolor=blue></td><td colspan=2 width=2px></td></tr><tr><td height=3px width=1px rowspan=3 bgcolor=blue></td><td></td></tr><tr><td height=1px width=1px rowspan=1 bgcolor=blue></td></tr><tr><td></td></tr><tr><td colspan=2 height=1px width=2px></td></tr><tr><td colspan=3 height=1px width=3px></td></tr><tr><td colspan=4 height=1px width=4px></td></tr></table></td><td class=MS>This Report has been generated on Fri. 02/03/07 11:49:44.</td></TR></table><br><TABLE WIDTH='100%' CELLPADDING=0 CELLSPACING=0><TR VALIGN=TOP><TD>test</TD></TR></TABLE></TD></TR></T ABLE>

ThomasP
# Posted: 2 Mar 2007 04:54


If you ask what is this strange table with bgcolor=blue, it's a working transparent GIF...

mvf
Member
# Posted: 4 Mar 2007 22:50


What is version of OS, Internet Explorer?

ThomasP
# Posted: 5 Mar 2007 07:57


IE7 and Win XP2 with all updates

IE 7.0.5730.11

WinXP SP2 5.1.2600

mvf
Member
# Posted: 5 Mar 2007 22:37


Please check your DEP (Data Execution Prevention) settings. You can find it this way:
- Start -> Settings -> Control Panel -> System.
- Click the Advanced tab and, under Performance, click Settings.
- Click the Data Execution Prevention tab.
You need the "Turn on DEP for essential Windows programs and services
only" option to be checked.

 

 

Powered by miniBB 2.0 RC7 © 2001-2004 Page creation time (sec.): 0.018

 

Page top