Two Pilots™    Home  |  Navigation  |  Site Map  |  Products  |  Download  |  Prices  |  For Partners  |  Support


All forums · Statistics · Search ·

Two Pilots forum / For software developers / PDFCreatorPilotLib + HTML2PDFAddOn + 32/64 bit OS
Author Message
laurent
Member
# Posted: 2 Oct 2008 08:22


Hello

i'am trying to use HTML2PDF component.

My development PC is XP PRO 32 bit and VS2005 c#
the code runs fine on this environement, but i need to deploy the software on a 2003 server 64 bits OS

i have done severals tests :
compiling any cpu and installing X64 versions of the component
doesn't work and gives CLSID not found

compiling any cpu and installing X32 versions of the component
doesn't work and gives CLSID not found

compiling X86 and installing X32 versions of the component
doesn't work and gives "Attempted to read or write protected memory"

So i have tried to use a X64 dev pc ( Vista 64 bits)
1) installation of X64 bits version of html + pdf creator
2) VS2005 => impossible to add the reference to 64 bits dll ( there is a yellow exclamation icon) and using don't find the library
=> is it normal that the software installs the 64 bits componenets in programfiles (x86) ?
=> is it normal that the HTML testing utility fails with "invalide configuration files"

as it is not working, i have removed from vista 64 the X64 version and installed the 32 bits version of the tools
1) this time the HTML testing utility works fine ( something that it is not working on my XP 32 )
2) the reference to dll 32 works

compiling any cpu
doesn't work and gives CLSID not found : normal

compiling X64
doesn't work and gives CLSID not found : normal

compiling X86
works !!! ( which is normal )

so i have taken this version of the software ( X86 ) and copy it on the 2003 server 64 bit OS
=> fails "Attempted to read or write protected memory"

Conclusion : that drives me crazy
ps : i have also check the DEP settings and tried multiple configuration : enable , disable with http unticked, disable with http ticked

if you can help it will be appreciate

laurent

laurent
Member
# Posted: 2 Oct 2008 08:28


it's me again.

Something i want to add :
when i'am adding a reference to your libraries, i use Browse and select the dll because it is not displayed in the com Tab
=> when i look at http://www.colorpilot.com/pdfcreatorpilotmanual/Ho w_to_create_a_new_PDF_document_4.html, the dll appears in the com object, am i missing something ?

laurent

laurent
Member
# Posted: 17 Oct 2008 00:45


I have checked again and it seems that my DEP setting was wrong.
So now it's running on a 2003 X64 with x86 compilation and 32 bit version library
but i still don't know how to reference the 64 bits version on a XP64 vS2005

can you help on this ?

max.f
# Posted: 17 Oct 2008 01:11


You need to use x64 versions of PDF Creator and HTML2PDF Addon (available on the web pages for these products). When you install both of them they should appear on the "COM" tab in the "Add reference" dialog. Then you should add needed COMs from this tab.

--
Max Filimonov

laurent
Member
# Posted: 20 Oct 2008 07:52


Hello

As i have written in my first post :

So i have tried to use a X64 dev pc ( Vista 64 bits)
1) installation of X64 bits version of html + pdf creator
2) VS2005 : the 2 components don't appear in the com pane, so i have tried using browse
=> impossible to add the reference to 64 bits dll ( there is a yellow exclamation icon) and using don't find the library

=> is it normal that the software installs the 64 bits componenets in programfiles (x86) ?
=> is it normal that the HTML testing utility fails with "invalid configuration files"

Thanks

max.f
# Posted: 21 Oct 2008 00:18


I informed ourdevelopers about x64 installation problems. We?ll contact you when we find out what is the problem.

--
Max Filimonov

laurent
Member
# Posted: 11 Dec 2008 10:05


Any news ?

Vitaliy Shibaev
Member
# Posted: 12 Dec 2008 04:42


Hi Laurent,

Max is on vacation now, he returns 15 Dec.
We improved installers for x64, but I don't sure that all bugs fixed. Max will reply you after returning.

Best regards,
Vitaliy Shibaev
Two Pilots

laurent
Member
# Posted: 18 Dec 2008 03:18


OK thanks

Garth
# Posted: 5 Jun 2010 16:03


I'm having this exct same problem (and it's a year and a half later). Has there been any progress???

Anastasiya
Member
# Posted: 9 Jun 2010 00:52


Der Garth,

The answer was sent you by mail.

Anastasiya Bednaya
Two Pilots
http://www.colorpilot.com

 

 

Powered by miniBB 2.0 RC7 © 2001-2004 Page creation time (sec.): 0.014

 

Page top