Two Pilots™    Home  |  Navigation  |  Site Map  |  Products  |  Download  |  Prices  |  For Partners  |  Support


All forums · Statistics · Search ·

Two Pilots forum / For software developers / Blank PDF - Slow Process Time on First Run
Author Message
allaboutduncan
Member
# Posted: 19 May 2008 08:47


We've been using the Pilot DLL for some time and the HTML2PDF add-on for over a year. Recently, we've been receiving blank PDF files when the PDF is created. The blank file is named correctly based on the script, but is only 12kb in size and is a single blank page.

Re-running the script with the same data produces the correct PDF.

On the initial run, the PDF creation process is very slow and the resulting PDF is the blank 12kb file. Submitting the same form with the same data immediately, the file works as it should and a PDF is produced almost immediately.

DEP is disabled on the machine and the process has been running fine until recently (no changes to hardware, other than Windows updates).

It's practically impossible to test or diagnose, since the 2nd submission works. It seems like PDF process goes to "sleep" and doesn't "wake-up" until the 2nd submission.

Any ideas. Thanks.

mvf
Member
# Posted: 20 May 2008 02:20


Hello, Allaboutduncan,
Well, its hard to advise something as HTML2PDF addon did not change.
If you are talking about using of PDF Creator and addon in a web application, then it might be a problem in application or web server (or web server's application's pool)...

--
Max Filimonov.

 

 

Powered by miniBB 2.0 RC7 © 2001-2004 Page creation time (sec.): 0.016

 

Page top